Access to Srv which install in one workstation

Author Subject: Access to Srv which install in one workstation
Sandy Lee Posted At 09:14:10 06/12/2003
Hi Support,
I have just install LibrarySrv in my machine which was in a lan environment. And I also use LibraryPublisher to add Project to the library. Also, I have issue a certificate and login id to one of my colleague. The question is he cannot visit my library in his machine. He had use LibraryPublisher to view the library. I think he is connection to my LibrarySrv already because I can see his login in my server. What should I do so that he can use the library??
Thanks
Sandy
Librarian Support Re: Access to Srv which install in one workstation (Currently 0 replies)
Posted At 09:59:22 06/12/2003

Hi Sandy
Check "User Administration" on LibrarySvr to see if your colleague's account is locked out. If it is then highlight his account name in the list and click on the "Toggle Lock Status" button. This will unlock his account and should give him normal access to the library.
If this is not the problem then I suggest that you generate a new certificate for his account and have him import it into LibraryCardPublisher.
One last thing to check is that he may be successfully logged in to the library but cannot see the up to date contents of the library. Try double-clicking with the right mouse button on the library root. This is the top entry in the list of projects in LibraryCardPublisher.
Let us know if this helps resolve the problem.
Regards
Librarian Support.
Sandy Lee Re: Access to Srv which install in one workstation (Currently 0 replies)
Posted At 21:33:05 06/12/2003

Thanks support
I have issue another cert. for my colleague with his workstation no. and without port no. again. Also set him to Unlocked. But he still cannot see my library. Also his librarypublisher always disconnect him automatically after a few seconds. And I check the server again and he chage to locked user again.
Pls kindly reply.
Sandy
Librarian Support Re: Access to Srv which install in one workstation (Currently 0 replies)
Posted At 03:24:33 06/13/2003

Hi Sandy
It is normal for LibraryCardPublisher to disconnect a user within a few seconds if their security certificate cannot be properly validated by LibrarySvr. So it seems that the problem is about the certificate for this user.

When you issued a new certificate for this user did he then import the new certificate into his copy of LibraryCardPublisher? One problem that we have encountered is that users accidentally import the old certificate rather than the new one that was just generated. This results in exactly the behaviour that you are describing.

What we suggest is that you once again change the user status to unlocked. Generate yet another certificate for this user. The file name of the certificate will include the date and time of creation of the certificate. Get the user to import this new certificate into LibraryCardPublisher and then try and access the library again. Make sure he is importing the newest certificate that you create, otherwise you will run into the same problem again.

If this does not resolve the problem let us know and we will try and identify any other issues that might be causing this problem.

Regards
Librarian Support

Post Reply:
Name:
E-Mail:
Subject:
Message: